Project

General

Profile

Feature #10176

Redesign the Donate page

Added by Anonymous over 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Fundraising
Target version:
Start date:
08/25/2016
Due date:
% Done:

100%

Feature Branch:
web/10176-redesign-donate
Type of work:
Website
Blueprint:
Starter:
Affected tool:

Description

URL for Reference: https://tails.boum.org/contribute/how/donate/index.en.html

Perhaps on this page we could move the Bitcoin, Bank Wire (side note: excluding a grant, has anyone ever sent a bank wires to make a donation?), and PayPal sections to the top portion of the page, right below the purple "Make a Donation" header.

If someone has already clicked the "Donate" button, we should try to connect them with a donation method immediately on the page they have sought to do so on. The current text at the top of the page leads them to two pages where they cannot donate.

We could also probably remove "Bitcoin" and "PayPal" from the "Ways to Donate" section since it would be clear by seeing those two options first at the top of the page. Also, we could change it to "Other Ways to Donate" and include the FPF link, Tor link, and then a link to our contribute page.

Lastly, a couple of other notes:
1. Is it necessary to note that Bitcoin isn't anonymous? PayPal and/or any other method is not going to be anonymous either but we do not notate that.
2. For BTC, perhaps we should show a QR code in addition to the public key, since any transcription error would make the donation unrecoverable. This could lessen those chances if we give the user a choice.

Thoughts?

1BvBMSEYstWetqTFn5Au4m4GFg7xJaNVN2.png View (407 Bytes) sajolida, 10/14/2015 09:11 AM


Subtasks

Feature #11722: Review JavaScript on new donation pageResolved


Related issues

Related to Tails - Feature #10045: Set up Flattr section in our Donations page Resolved 08/15/2015
Related to Tails - Feature #9857: Receive donations directly at Riseup Resolved 08/01/2015
Related to Tails - Feature #11824: Rewrite JS on /donate with vanilla JS Resolved 09/22/2016
Related to Tails - Bug #11821: Have a configuration for compiling our custom version of Bootstrap Confirmed 09/21/2016
Blocks Tails - Feature #9855: Donation campaign 2016 Resolved 06/04/2015

Associated revisions

Revision 002b0aaa (diff)
Added by sajolida over 3 years ago

Replace old donation page with the new one (Will-fix: #10176)

Revision 8699f5c8
Added by anonym over 3 years ago

Merge remote-tracking branch 'origin/web/10176-redesign-donate'

Fix-committed: #10176

History

#1 Updated by sajolida over 4 years ago

  • Status changed from New to Confirmed

#2 Updated by sajolida over 4 years ago

Thanks for the initiative!

(side note: excluding a grant, has anyone ever sent a bank wires to make a donation?)

Yes, we receive donations by wire transfer from Europe sometimes (5 in
December 2014), maybe that's easier for European because our bank
account is in Europe.

If someone has already clicked the "Donate" button, we should try to
connect them with a donation method immediately on the page they have
sought to do so on. The current text at the top of the page leads
them to two pages where they cannot donate.

Yes, I agree with that. I'm also in favor of getting rid of these links
from the top of the page. Still, do you think we should keep the link to
"Discover who you are helping around the world when donating to Tails"
somewhere on that page?

We could also probably remove "Bitcoin" and "PayPal" from the "Ways
to Donate" section since it would be clear by seeing those two
options first at the top of the page.

Agreed. There's a bit of information duplication on this page and
there's surely stuff we can simplify or structure better to make the
whole page more efficient.

Also, we could change it to
"Other Ways to Donate" and include the FPF link, Tor link, and then a
link to our contribute page.

I'm not sure we should keep the link to the Tor Project, our page should
focus on donating to Tails. I would be in favor of removing this as a
possibility.

Lastly, a couple of other notes: 1. Is it necessary to note that
Bitcoin isn't anonymous?

We added this to debunk a myth. People sometimes wrongly think that
Bitcoin is anonymous while they probably don't believe that Paypal is
anonymous. Still, I would be fine with removing that info to simplify
the page. It's not really our job to explain Bitcoin to its users.

PayPal and/or any other method is not going
to be anonymous either but we do not notate that.

2. For BTC, perhaps
we should show a QR code in addition to the public key, since any
transcription error would make the donation unrecoverable. This could
lessen those chances if we give the user a choice.

Right, I started using QR codes for the website while working on the
Installation Assistant, see d6ae549 for how to create them under Linux
(or Tails).

#3 Updated by sajolida over 4 years ago

  • Category set to Fundraising

We'll also soon have to include Flattr on this page. You should check #10045 and its corresponding branch. Maybe we should merge #10045 before working on this too much.

#4 Updated by sajolida over 4 years ago

  • Related to Feature #10045: Set up Flattr section in our Donations page added

#5 Updated by sajolida over 4 years ago

  • Related to Feature #9857: Receive donations directly at Riseup added

#6 Updated by sajolida over 4 years ago

Also, as we're working on #9857, we want to receive US donations directly at RiseupLabs (instead of going first through FPF) this time. Riseup is OK with this in principle but they have to give us their final aggreement and we have to see how this works in practice. Most likely this will be a second Paypal account.

So maybe we should end up with a page that puts more emphasis on Paypal with US and EU put in parallel with a button to toggle between the two. Then wire transfer could be minor options hidden by default.

Hiding and toggling can be done in ikiwiki using the [[!toggle directive]].

Otherwise non-fiat systems (Bitcoin and Flattr) could be listed below these first Paypal forms.

#7 Updated by sajolida over 4 years ago

Here is a QR code for our Bitcoin address.

#8 Updated by sajolida almost 4 years ago

  • Subject changed from Revise Information Architecture on Donate Page to Redesign the Donate page

Also:

  • Make sure it works well without JavaScript
  • Consider having a troubleshooting link (at least to do stats on it)
  • Limit distractions and links to the bare minimum (hide the sidebar?)

#9 Updated by sajolida over 3 years ago

#10 Updated by sajolida over 3 years ago

#11 Updated by sajolida over 3 years ago

#12 Updated by sajolida over 3 years ago

  • Assignee set to sajolida
  • QA Check set to Ready for QA
  • Feature Branch set to web/10176-redesign-donate

#13 Updated by sajolida over 3 years ago

  • Assignee deleted (sajolida)

Call sent on https://mailman.boum.org/pipermail/tails-project/2016-September/000576.html.

If nobody formally takes over the review, I'll increment based on the feedback on that mailing list.

#14 Updated by sajolida over 3 years ago

  • Assignee set to u

After two rounds of feedback on the mailing list I consider this done. I'm reassign this to u for her to review the JavaScript (and maybe a bit of HTML).

u: What realistic ETA could you give for this? If you can't review it in the next week, maybe I'd like to ask other people if they can do it faster.

#15 Updated by sajolida over 3 years ago

The review is planned for next week.

#16 Updated by u over 3 years ago

  • Assignee changed from u to sajolida
  • QA Check changed from Ready for QA to Dev Needed
  • Feature Branch changed from web/10176-redesign-donate to 451f:web/10176-redesign-donate

#17 Updated by u over 3 years ago

  • QA Check deleted (Dev Needed)
  • Feature Branch changed from 451f:web/10176-redesign-donate to web/10176-redesign-donate

Copied my review here: https://labs.riseup.net/code/issues/11722#note-4

I modified the JS and a bit of HTML until now, not the CSS.
As for the design itself it looks good to me as said on the mailinglist already.

#18 Updated by sajolida over 3 years ago

  • Related to Feature #11824: Rewrite JS on /donate with vanilla JS added

#19 Updated by sajolida over 3 years ago

  • Related to Bug #11821: Have a configuration for compiling our custom version of Bootstrap added

#20 Updated by sajolida over 3 years ago

  • Assignee deleted (sajolida)
  • QA Check set to Ready for QA

So, I merged the page on the production web site some days now.

Now I prepared a commit (002b0aa) to replace the old donation page. Can someone review and merge this? Beware, it will rebuild the whole website because it updates the sidebar.

#21 Updated by sajolida over 3 years ago

Temptatively assiging to intrigeri not to loose this from sight, but other people can do it (bertagaz, anonym, u).

#22 Updated by sajolida over 3 years ago

  • Status changed from Confirmed to In Progress

#23 Updated by intrigeri over 3 years ago

  • Assignee set to intrigeri
  • Target version set to Tails_2.7

sajolida wrote:

Temptatively assiging to intrigeri [...]

Doing that, then.

#24 Updated by anonym over 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

I reviewed it on request from sajolida.

Also available in: Atom PDF