Project

General

Profile

Feature #10154

Feature #10153: Automated tests: phase two

Store automated test videos with other artifacts

Added by bertagaz over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
09/03/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
No
Affected tool:

Description

As discussed while designing the automated tests, storing the resulting videos is interesting to debug what failed. So we should store them as artifacts.

Storing all videos produced by the automated test suite doesn't make much sense. We're interested in the failing scenarios.


Related issues

Duplicated by Tails - Feature #10156: Store only the failed scenario videos as artifacts Duplicate 09/03/2015
Blocked by Tails - Feature #10148: Split test suite capture videos per-scenario Resolved 09/02/2015

History

#1 Updated by bertagaz over 4 years ago

  • Target version set to Tails_1.7
  • Parent task set to #10153

#2 Updated by bertagaz over 4 years ago

  • Blocked by Feature #10155: Rotate automated test videos artifacts added

#3 Updated by bertagaz over 4 years ago

  • Blocks Feature #10156: Store only the failed scenario videos as artifacts added

#4 Updated by intrigeri over 4 years ago

  • Blocked by Feature #10148: Split test suite capture videos per-scenario added

#6 Updated by bertagaz over 4 years ago

  • Assignee changed from bertagaz to intrigeri
  • % Done changed from 0 to 80
  • QA Check set to Ready for QA

Since run 9 of the test_Tails_ISO_devel job the video capture are archived in Jenkins build artifacts.

#7 Updated by intrigeri over 4 years ago

  • Blocks deleted (Feature #10156: Store only the failed scenario videos as artifacts)

#8 Updated by intrigeri over 4 years ago

  • Duplicated by Feature #10156: Store only the failed scenario videos as artifacts added

#9 Updated by intrigeri over 4 years ago

  • Description updated (diff)

(Imported bit of spec from #10156.)

#10 Updated by intrigeri over 4 years ago

  • Blocked by deleted (Feature #10155: Rotate automated test videos artifacts)

#11 Updated by intrigeri over 4 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 80 to 100
  • QA Check changed from Ready for QA to Pass

Also available in: Atom PDF