Project

General

Profile

Bug #10124

po_translatable_pages is unstable on boum.org

Added by sajolida over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
08/31/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Website
Blueprint:
Starter:
Affected tool:

Description

When we merged #9279, the po_translatable_pages configuration had inc/stable_i386_iso_size_*_unit. This worked when building the website on Tails but produced https://labs.riseup.net/code/attachments/download/919/Screenshot%20from%202015-08-28%2012_12_05.png when building on boum.org.

We changed to inc/stable_i386_iso_size_mb_unit or inc/stable_i386_iso_size_mib_unit and refreshed all the page and it got fixed. But then broke again with the release of 1.5.1

We should try to reproduce this behaviour in ikiwiki from sid and track that bug down before the next release!


Related issues

Related to Tails - Bug #9279: ISO file size unit is not translatable on the download page Resolved 04/26/2015
Related to Tails - Bug #9671: rss and atom feed of l10n news show po file source Resolved 07/03/2015
Related to Tails - Bug #6907: ikiwiki po plugin does not play well with inline directives Resolved 12/03/2018 03/12/2019

History

#1 Updated by sajolida over 4 years ago

  • Related to Bug #9279: ISO file size unit is not translatable on the download page added

#2 Updated by sajolida over 4 years ago

See also #9279#note-12.

#3 Updated by intrigeri over 4 years ago

We should try to reproduce this behaviour in ikiwiki from sid and track that bug down before the next release!

In passing, note that other changes pushed via Git (not necessarily a release) might trigger this bug.

#4 Updated by sajolida over 4 years ago

  • Priority changed from Normal to Elevated
  • Target version changed from Tails_1.6 to Tails_1.7

Postponing and so raising priority.

#5 Updated by intrigeri over 4 years ago

  • Related to Bug #9671: rss and atom feed of l10n news show po file source added

#6 Updated by intrigeri over 4 years ago

For the record, I've modified our oldest ticket about this class of problems (#6907) so that it tracks their likely root cause, so I am not sure if it's worth keeping this specific ticket around. If there are good reasons to keep it open, then we should give it a better title since we've seen such problems for years (=> not specific to sid) and at least I have sometimes seen it locally (see my debugging on #9671 => not specific to boum.org).

#7 Updated by sajolida over 4 years ago

  • Related to Bug #6907: ikiwiki po plugin does not play well with inline directives added

#8 Updated by sajolida over 4 years ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (sajolida)

So I spent a bit of time trying to reproduce this and failed.

Here is what I did:

  • Start a fresh Tails with persistence.
  • Clone our repo.
  • Build the website in persistence as well, from each one of these commits successively (doing reset --hard after each ikiwiki refresh):
    • c24fff3 master before 1st merge
    • 6270e84 1st merge
    • 2699883 master before 2nd merge
    • 85bdc71 2nd merge
    • a0f7b0a inc/stable_i386_iso_size_*_unit created problems on the production site
    • a82b893 master before 1.5.1
    • 6f0ad0a 1.5.1

Also available in: Atom PDF