Project

General

Profile

Feature #10115

Add a splash screen to Tails persistence assistant

Added by tchou almost 4 years ago. Updated 10 months ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
Persistence
Target version:
-
Start date:
08/28/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:

Description

During test session we felt that the Persistence Assistant was taking some time to start. Not a big deal, but a few second. Maybe we could have a splash screen while the software is lunching ?


Related issues

Related to Tails - Feature #6876: Have the incremental upgrade process use less RAM In Progress 03/07/2014
Related to Tails - Feature #6877: Research how the check for upgrades could require less RAM Rejected 03/07/2014
Related to Tails - Feature #15827: Give feedback while the persistence setup is starting Confirmed 08/21/2018

History

#1 Updated by intrigeri almost 4 years ago

  • Related to Feature #6876: Have the incremental upgrade process use less RAM added

#2 Updated by intrigeri almost 4 years ago

  • Related to Feature #6877: Research how the check for upgrades could require less RAM added

#3 Updated by intrigeri almost 4 years ago

  • Assignee changed from intrigeri to tchou

During test session we felt that the Persistence Assistant was taking some time to start. Not a big deal, but a few second. Maybe we could have a splash screen while the software is lunching ?

I've never done that in Perl+Gtk3, but I guess a splash screen should be relatively easy to add. Perhaps doing it with a shell wrapper would be more effective, though: if we have to load Perl and all the libraries + GIR we need to get the splash screen, then perhaps it would appear too late during the startup process, and then it would be mostly useless.

Another option would be to port the code from Moose + heavy extensions (the OO framework currently used) to Moo or Moops. If we choose this way for the Upgrader (#6876, #6877) then we'll have to do it for our perl5lib, and then it makes sense to do it for the persistence assistant as well. The other way round is valid as well: if we do this change for the persistence assistant, then we probably also have to do it for the perl5lib and then the Upgrader. My rough initial guess is that the initial porting is not that much work, and then it's a looong cycle of "run test suite, see breakage, debug, fix, rinse and repeat". Thankfully we have good test coverage for all this code, so that's not too scary. Now, IMO this specific ticket is not worth doing all that work (so the splash screen may be the best short-term option), but perhaps the Upgrader will trigger it anyway sooner or later.

If you agree with my analysis, let's turn this ticket into a "Code" one, that would be about adding a splash screen, and nothing more.

#4 Updated by sajolida almost 4 years ago

  • Category set to Persistence
  • Status changed from New to Confirmed
  • Assignee deleted (tchou)
  • Type of work changed from Discuss to Code

#5 Updated by u almost 2 years ago

  • Subject changed from Accelerate Persistence Assistant launch to Add a splash screen to Tails persistence assistant
  • QA Check deleted (Info Needed)

#6 Updated by u almost 2 years ago

  • Priority changed from Normal to Low

I'm lowering priority because I think we don't currently have the resources to make this happen ourselves.

#7 Updated by u over 1 year ago

  • Tracker changed from Bug to Feature
  • Type of work changed from Code to User interface design

It sounds like our UX experts should propose a solution or reject this feature request.

#8 Updated by u 10 months ago

  • Assignee set to sajolida
  • QA Check set to Info Needed

@sajolida: should we keep this feature request open?

#9 Updated by sajolida 10 months ago

  • Related to Feature #15827: Give feedback while the persistence setup is starting added

#10 Updated by sajolida 10 months ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (sajolida)
  • QA Check deleted (Info Needed)
  • Type of work changed from User interface design to Discuss

I'll reject this as overkill. We should instead add the usual spinner while it opens. See you on #15827.

Also available in: Atom PDF