Project

General

Profile

Bug #10114

Tails Installer should display accurate progress information instead for freezing on "Synchronizing data on disk..."

Added by tchou about 4 years ago. Updated about 1 year ago.

Status:
Confirmed
Priority:
Low
Assignee:
-
Category:
Installation
Target version:
-
Start date:
08/28/2015
Due date:
% Done:

0%

Feature Branch:
feature/gtk3+fancy-progress-bar
Type of work:
Research
Blueprint:
Starter:
Affected tool:
Installer

Description

During test sessions, Tails Installer was stucking a long moment at 95%.
I don't kown if it's happening often. Any feedback ?

If it's often stucking, could we have an other way to indicate the progression ?

Screenshot from 2015-09-01 16_13_01.png View (43.1 KB) sajolida, 09/01/2015 09:13 AM


Related issues

Related to Tails - Bug #11208: Rephrase note about "progress bar freezing for some time around 95 percent" Resolved 03/09/2016
Related to Tails - Feature #14548: Fix issues identified in the expert review done by jaster on our installation instructions Confirmed 09/28/2013
Related to Tails - Feature #6335: Display a waiting mouse cursor when the Installer working Duplicate 10/04/2013
Related to Tails - Feature #14544: Spend software developer time on smallish UX improvements In Progress 08/31/2018

History

#1 Updated by intrigeri about 4 years ago

  • Assignee changed from intrigeri to tchou

During test sessions, Tails Installer was stucking a long moment at 95%.
I don't kown if it's happening often. Any feedback ?

On what version of Tails did you see that? We've fixed a bug that caused this symptom ~6 months ago, and I've never seen it happen since.

#2 Updated by tchou about 4 years ago

  • Status changed from New to Resolved

No idea, it was 3 month ago. Let's considere that as been fixed (except if it pop ups during the next tests).

#3 Updated by tchou about 4 years ago

  • Assignee deleted (tchou)

#4 Updated by sajolida about 4 years ago

This is still happening for me every time. The exact symptoms can be slightly different (for example this time it got stuck at 87%, when testing liveusb-creator on the command line it got stuck at 99%). See screenshot in attachment.

This happens at the stage of "Synchronizing data on disk..." so maybe there's nothing we can do or maybe it's very hard to fix and not worth it but I swear this still happens.

#5 Updated by intrigeri about 4 years ago

This is still happening for me every time. The exact symptoms can be slightly different (for example this time it got stuck at 87%, when testing liveusb-creator on the command line it got stuck at 99%). See screenshot in attachment.

This happens at the stage of "Synchronizing data on disk..." so maybe there's nothing we can do or maybe it's very hard to fix and not worth it but I swear this still happens.

Does the installation eventually finish for you?

#6 Updated by sajolida about 4 years ago

  • Subject changed from Tails Installer: prevent to get stuck à 95% to Tails Installer freezes for too long on "Synchronizing data on disk..."

Yes it does. So maybe we're just having some misunderstanding here. Tchou and I are not referring to failed installation but to bad feedback in the progression bar. Trying to rename the ticket.

#7 Updated by sajolida about 4 years ago

  • Category set to Installation

#8 Updated by intrigeri about 4 years ago

Yes it does. So maybe we're just having some misunderstanding here.

Absolutely!

Tchou and I are not referring to failed installation but to bad feedback in the progression bar. Trying to rename the ticket.

Thanks, now I get it. Language problem. Perhaps my understanding of "stuck" is too restrictive.

#9 Updated by intrigeri almost 4 years ago

Alan started a branch (feature/gtk3+fancy-progress-bar) in the Tails Installer Git repo in July, that IIRC replaces the buggy percentage progress bar with a "pulsing" one that indicates that the software is still working, without displaying an erroneous percentage. Sadly, he had no time back then to bring this branch into a good enough shape.

IMO this would be a good way to address the UX concerns this ticket is about. Do we agree on this?

#10 Updated by sajolida almost 4 years ago

  • Assignee set to alant
  • QA Check set to Info Needed

We could probably learn more about the UX of progress bars elsewhere but what you are proposing sounds like a good idea; and even more if Alan almost has a branch to show us.

Assigning to him for ETA, feelings, etc.

#11 Updated by segfault over 3 years ago

I took a look at this because I think it's pretty annoying. What takes so long is the 'sync' operation of the tails-installer after extracting the ISO with 7z. Now that we are at jessie, we can use rsync with the --info=progress2 option which we could use instead of 7z. This way we would get a nice progress percentage output which we could parse and adjust the progress bar accordingly. But it might take longer to copy the files this way. I will time both methods, 7z and rsync with progress2, when I find free time for it.

#12 Updated by intrigeri over 3 years ago

I took a look at this because I think it's pretty annoying.

Great, thanks :)

What takes so long is the 'sync' operation of the tails-installer after extracting the ISO with 7z.

Correct (assuming the system has enough free memory to extract into memory cache instead of flushing out directly to disk; otherwise, the actual extraction step will be the one that takes a long time).

Now that we are at jessie, we can use rsync with the --info=progress2 option which we could use instead of 7z. This way we would get a nice progress percentage output which we could parse and adjust the progress bar accordingly.

Given in most cases the actual files extraction is not the culprit (as discussed above), for this to work I guess you would need to run rsync in a way that it bypasses in-memory disk cache, right? I'm curious how you do that.

Also, I'm curious how you indend to use rsync to extract files from an ISO image. Using fuseiso or similar, perhaps?

On my Debian unstable system, 7z has a "-bd Disable percentage indicator" option. So perhaps it actually already provides progress info that we could use?

#13 Updated by intrigeri over 3 years ago

Alan, ping?

#14 Updated by intrigeri over 3 years ago

sajolida wrote:

Assigning to him for ETA, feelings, etc.

Two month later without any answer should give us an idea of the (lack of) ETA, I guess :)

#15 Updated by intrigeri over 3 years ago

  • Related to Bug #11208: Rephrase note about "progress bar freezing for some time around 95 percent" added

#16 Updated by sajolida over 3 years ago

  • Type of work changed from Discuss to Research

There's more to research than to discuss on this one.

#17 Updated by sajolida over 1 year ago

  • Related to Feature #14548: Fix issues identified in the expert review done by jaster on our installation instructions added

#18 Updated by sajolida over 1 year ago

  • Assignee changed from alant to kurono
  • QA Check changed from Info Needed to Dev Needed
  • Feature Branch set to feature/gtk3+fancy-progress-bar

kurono: Would you be interested in checking the state of Alan's branch?

#19 Updated by intrigeri over 1 year ago

kurono: Would you be interested in checking the state of Alan's branch?

IIRC it introduced regressions at least in some cases.

#20 Updated by kurono over 1 year ago

  • Target version set to Tails_3.7

#21 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.8

#22 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.9

#23 Updated by kurono about 1 year ago

  • Assignee deleted (kurono)
  • Target version deleted (Tails_3.9)

#24 Updated by u about 1 year ago

#25 Updated by u about 1 year ago

  • Priority changed from Normal to Low

So we have a branch but nobody to review it. It's possibly outdated. We might soon ship a USB image. → Lowering priority.

#26 Updated by intrigeri about 1 year ago

u wrote:

So we have a branch but nobody to review it.

FYI that branch did not work well enough so what's needed is research + coding, not a review.

We might soon ship a USB image.

I don't think that's relevant here as long as the plan is to keep shipping Tails Installer.

#27 Updated by intrigeri about 1 year ago

#28 Updated by u about 1 year ago

  • Related to Feature #6335: Display a waiting mouse cursor when the Installer working added

#29 Updated by u about 1 year ago

  • Subject changed from Tails Installer freezes for too long on "Synchronizing data on disk..." to Tails Installer show progress bar when freezing on "Synchronizing data on disk..."

#30 Updated by u about 1 year ago

There was another idea to make this visible: on #6335 using a waiting mouse cursor.

#31 Updated by intrigeri about 1 year ago

  • Subject changed from Tails Installer show progress bar when freezing on "Synchronizing data on disk..." to Tails Installer should display accurate progress information instead for freezing on "Synchronizing data on disk..."

(We already have a progress bar, so let's make the title reflect the fact it's buggy, not missing :)

#32 Updated by sajolida about 1 year ago

  • Related to Feature #14544: Spend software developer time on smallish UX improvements added

Also available in: Atom PDF