Project

General

Profile

Feature #10082

Bug #15945: Drop Python 2 in Tails 5.0

Feature #5958: Port our custom software to Python 3

Port tails-about to Python 3

Added by alant about 4 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08/24/2015
Due date:
% Done:

100%

Feature Branch:
sycamoreone:10082-port-tails-about-to-python3
Type of work:
Code
Blueprint:
Starter:
Yes
Affected tool:

Description

/usr/local/bin/tails-about should be migrated to Python3/PyGI.

To test: start a Tails, select "More options", set an admin (sudo) password, apply your changes, and then click "About Tails" in the applications menu.

Associated revisions

Revision 839ccf7b
Added by anonym about 3 years ago

Merge remote-tracking branch 'sycamoreone/10082-port-tails-about-to-python3' into devel

Fix-committed: #10082

History

#1 Updated by alant about 4 years ago

  • Parent task set to #5958

#2 Updated by alant about 4 years ago

  • Status changed from New to Confirmed

#3 Updated by intrigeri about 4 years ago

  • Subject changed from Migrate tails-about to python3 to Port tails-about to Python 3

#4 Updated by intrigeri about 4 years ago

  • Description updated (diff)

#5 Updated by intrigeri about 4 years ago

  • Starter set to Yes

#6 Updated by muri over 3 years ago

  • Assignee set to anonym
  • Feature Branch set to muri:10082-port-tails-about-to-python3

hi,

i've looked into that. i'm not a python coder (yet ;)), but it's running with python3 now and pylint3 doesn't complain that much anymore (most of the stuff i changed were changes to make pylint3 happy...).
if that one is oke, i'll do the next one

#7 Updated by intrigeri over 3 years ago

  • QA Check set to Ready for QA

#8 Updated by BitingBird over 3 years ago

  • Target version set to Tails_2.5

Assigning to the next version, because it seems it's not tracked otherwise :)

#9 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_2.5 to Tails_2.6

Not suitable for a point-release.

#10 Updated by intrigeri about 3 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

#11 Updated by sycamoreone about 3 years ago

  • QA Check changed from Ready for QA to Dev Needed

This still needs a few fixes related to the distinction between bytes and strings in Python 3. I can do that the next days.

#12 Updated by intrigeri about 3 years ago

  • Assignee changed from anonym to sycamoreone

Excellent, thanks! :)

#13 Updated by sycamoreone about 3 years ago

  • Description updated (diff)
  • Assignee changed from sycamoreone to anonym
  • % Done changed from 10 to 80
  • QA Check changed from Dev Needed to Ready for QA
  • Feature Branch changed from muri:10082-port-tails-about-to-python3 to sycamoreone:10082-port-tails-about-to-python3

I just added two small fixes and tested as described in the description.

There are some minor visual differences, but they are probably due to differences between Gtk2/3.

#14 Updated by anonym about 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 80 to 100
  • QA Check changed from Ready for QA to Pass

Looks good! Thanks sycamore!

#15 Updated by anonym about 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF