Project

General

Profile

Feature #10060

Warn when the in-memory filesystem is getting full

Added by DanOver about 4 years ago. Updated about 1 year ago.

Status:
Confirmed
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
08/18/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

When the internal memory is full, downloads fail without warning and extractions also fail.

GNOME has a notification mechanism for when internal hard disks get full. See https://search.disconnect.me/image?l=aHR0cHM6Ly9lbmNyeXB0ZWQtdGJuMC5nc3RhdGljLmNvbS9pbWFnZXM/cT10Ym46QU5kOUdjUjdDMVE4ZkVvMHlyRnhBcGQwWUFscDBFRmhScVc2WXV0bjNNTU81RldWampXRnZuMTBPUQ==.

We should have something similar in Tails for RAM (which is our internal disk somehow). The message should be custom and recommend to:

  • Remove files (downloads, etc.) or move them to the persistent volume.
  • Close applications
  • Restart

Related issues

Related to Tails - Feature #10064: Warn when persistent volume is getting full Confirmed 08/20/2015
Related to Tails - Feature #14544: Spend software developer time on smallish UX improvements In Progress 08/31/2018
Related to Tails - Feature #5502: Next time we bump RAM requirements: notify user at runtime if RAM requirements are not met Confirmed
Related to Tails - Feature #10064: Warn when persistent volume is getting full Confirmed 08/20/2015
Blocks Tails - Feature #7782: Warn the user when available RAM / memory is low Confirmed 08/14/2014

History

#1 Updated by BitingBird about 4 years ago

  • Assignee set to DanOver
  • QA Check set to Info Needed

Could you be more specific? How are you downloading, where, with what software?

#2 Updated by DanOver about 4 years ago

I do downloads with the TOR browser. But when the disk is full, downloads show a failure notice. Other programs also have failure related, but the nothing in Tails tells you that is because the disk space is full.

#3 Updated by sajolida about 4 years ago

  • Description updated (diff)
  • Status changed from New to Confirmed
  • Assignee deleted (DanOver)
  • Priority changed from Low to Normal
  • QA Check deleted (Info Needed)
  • Type of work changed from Debian to Code

In the description of the ticket you are mentioning "memory" getting full, but in your last comment you are mentioning "disk" getting full. I think both cases should be considered separately.

Regarding disks (external USB sticks, persistence, internal disks), I think we should have the usual GNOME notification about "low disk space": https://search.disconnect.me/image?l=aHR0cHM6Ly9lbmNyeXB0ZWQtdGJuMC5nc3RhdGljLmNvbS9pbWFnZXM/cT10Ym46QU5kOUdjUjdDMVE4ZkVvMHlyRnhBcGQwWUFscDBFRmhScVc2WXV0bjNNTU81RldWampXRnZuMTBPUQ==.

I tested and this mechanism doesn't work for the persistant volume, so I create a ticket just for that: #10064.

Regarding memory, yes, it would be super cool to have a warning about memory getting full as well. I'm surprised we don't have a ticket about that already... So I'm renaming this ticket and I'll let BitingBird mark it as a duplicate if we already have something about that elsewhere.

#4 Updated by sajolida about 4 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from Failure to recognize disk space to Warn when memory is getting full

#5 Updated by intrigeri about 4 years ago

  • Assignee set to DanOver
  • QA Check set to Info Needed

When saving stuff to non-persistent places in the filesystem, since Tails 1.5 one can (at least manually) see the remaining "disk" space (really: allocated memory to the read-write branch on tmpfs) with df /. I think this wasn't the case with 1.4.1, so perhaps this has been fixed => DanOver, can you reproduce this problem with Tails 1.5?

#6 Updated by intrigeri about 4 years ago

  • Subject changed from Warn when memory is getting full to Warn when the in-memory filesystem is getting full
  • Assignee deleted (DanOver)
  • QA Check deleted (Info Needed)

#7 Updated by sajolida about 3 years ago

  • Related to Feature #10064: Warn when persistent volume is getting full added

#8 Updated by u over 2 years ago

  • Status changed from Confirmed to Rejected

We have minimum requirements for RAM. This could be cool to have but, it's low prio. Missing space on the persistent volume is tracked on #10064.

#9 Updated by u over 2 years ago

  • Status changed from Rejected to Confirmed
  • Priority changed from Normal to Low

#10 Updated by u about 1 year ago

  • Subject changed from Warn when the in-memory filesystem is getting full to Warn when memory is getting full

#11 Updated by u about 1 year ago

  • Related to Feature #7782: Warn the user when available RAM / memory is low added

#12 Updated by u about 1 year ago

  • Status changed from Confirmed to Duplicate

That's actually a duplicate of #7782.

#13 Updated by intrigeri about 1 year ago

Subject: Warn when the in-memory filesystem is getting full

This ticket is about the read-write (tmpfs) branch of our aufs stack, which is allocated a fixed amount of RAM.

#14 Updated by intrigeri about 1 year ago

  • Subject changed from Warn when memory is getting full to Warn when the in-memory filesystem is getting full
  • Status changed from Duplicate to Confirmed

#15 Updated by intrigeri about 1 year ago

  • Related to deleted (Feature #7782: Warn the user when available RAM / memory is low)

#16 Updated by sajolida about 1 year ago

  • Related to Feature #14544: Spend software developer time on smallish UX improvements added

#17 Updated by sajolida 9 months ago

  • Related to Feature #7782: Warn the user when available RAM / memory is low added

#18 Updated by sajolida 9 months ago

  • Related to Feature #5502: Next time we bump RAM requirements: notify user at runtime if RAM requirements are not met added

#19 Updated by sajolida 9 months ago

  • Related to Feature #10064: Warn when persistent volume is getting full added

#20 Updated by intrigeri 9 months ago

  • Related to deleted (Feature #7782: Warn the user when available RAM / memory is low)

#21 Updated by intrigeri 9 months ago

  • Blocks Feature #7782: Warn the user when available RAM / memory is low added

Also available in: Atom PDF