Project

General

Profile

Feature #10038

List the dependencies of Weblate that are not in Debian

Added by sajolida about 4 years ago. Updated 5 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Infrastructure
Target version:
Start date:
08/14/2015
Due date:
% Done:

70%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:
Translation Platform

Description

list the dependencies which are in sid but not in stable or not in debian at all


Related issues

Related to Tails - Feature #10037: Help Weblate maintainers to add the package to Debian In Progress 08/14/2015

History

#1 Updated by sajolida about 4 years ago

  • Parent task set to #10034

#2 Updated by u about 4 years ago

*Weblate dependencies (from https://docs.weblate.org/en/latest/admin/install.html) *

apt-get install python git python-django translate-toolkit python-whoosh python-pil python-libravatar python-babel mercurial python-social-auth pyuca

  1. Web server option 1: nginx and uwsgi
    apt-get install nginx uwsgi uwsgi-plugin-python
  2. Web server option 2: Apache with mod_wsgi
    apt-get install apache2 libapache2-mod-wsgi
  3. Caching backend: memcached
    apt-get install memcached
  4. Database option 1: mariadb
    apt-get install mariadb-server
  5. Database option 2: mysql
    apt-get install mysql-server
  6. Database option 3: postgresql
    apt-get install postgresql
  7. SMTP server
    apt-get install exim4

*dependencies which are not in Wheezy (installation via PIP only): *
python-requests-oauthlib python-six python-openid python-django-crispy-forms

#3 Updated by u about 4 years ago

  • Assignee changed from u to sajolida
  • % Done changed from 0 to 20
  • QA Check set to Ready for QA

From what I remember all the dependencies are in Debian stable, but not oldstable (Wheezy)

#4 Updated by sajolida about 4 years ago

  • Assignee changed from sajolida to okgoogle

Why is this assigned to me? I probably created this ticket while wrapping up the notes from the summit but I have no personal interest in this.

#5 Updated by sajolida about 4 years ago

  • Assignee changed from okgoogle to u

Oops, sorry for okgoogle :)

#6 Updated by u about 4 years ago

As noted by Martin Borgert: A small step is still a step: pyuca is now in NEW, packaged by Daniel Stender. pyuca is an optional package for weblate, but we can Depend on it, as soon as it is in unstable.

#7 Updated by u about 4 years ago

sajolida wrote:

Why is this assigned to me? I probably created this ticket while wrapping up the notes from the summit but I have no personal interest in this.

sorry about the misunderstanding.

#8 Updated by u about 4 years ago

  • Status changed from Confirmed to Resolved

Closing.

#9 Updated by intrigeri over 2 years ago

  • % Done changed from 20 to 100

#10 Updated by intrigeri over 2 years ago

  • QA Check deleted (Ready for QA)

emmapeel found a few new deps (weblate 2.11) that are not in Debian, and filed RFPs that are marked as blocking the weblate RFP/ITP.

#11 Updated by emmapeel over 2 years ago

Yes, there are some new dependencies, because of changes on the
python-social-auth code, see:
https://github.com/omab/python-social-auth#deprecation-notice---2016-12-03

I have added 854895 and 854894 to the Debian BTS for them.

#12 Updated by u over 1 year ago

  • Status changed from Resolved to Confirmed
  • Assignee changed from u to drebs

Reopening this ticket as we decided during our first translation platform meeting, that we still need to capture this information on Redmine.

#13 Updated by u over 1 year ago

  • % Done changed from 100 to 40

#14 Updated by u over 1 year ago

  • Parent task deleted (#10034)

#15 Updated by u over 1 year ago

#16 Updated by drebs over 1 year ago

This is an up-to-date list of hard deps for Weblate 2.19 and their relation to Debian packages:

Weblate dependency Available version Action needed
Django (>= 1.11) 1.11.10 in stretch-backports install from stretch-backports
siphashc (>= 0.8) 1.0 source package for Debian
Translate-toolkit (>= 2.2.0) 2.2.5 in buster backport
Six (>= 1.7.0) 1.10.0 in stretch -
filelock (>= 3.0.1) 3.0.4 in buster backport
social-auth-core (>= 1.3.0) 1.7.0 source package for Debian
social-auth-app-django (>= 1.2.0) 2.1.0 source package for Debian
django-appconf (>= 1.0) 1.0.1 in stretch -
Whoosh (>= 2.7.0) 2.7.0 in stretch -
PIL or Pillow library 4.0.0 in stretch -
lxml (>= 3.1.0) 3.7.1 in stretch -
defusedxml (>= 0.4) 0.4.1 in stretch -
dateutil 2.5.3 in stretch -
django_compressor (>= 2.1.1) 2.2 in buster backport
django-crispy-forms (>= 1.6.1) 1.6.1 in stretch -
Django REST Framework (>=3.7) 3.7.7 in buster backport
user-agents (>= 1.1.0) 1.1.0 source package for Debian
oauthlib (>=0.6.3) 2.0.1 in stretch -

So, in summary, we'd need to create 4 new packages (and backport them) and also backport 4 other packages.

#17 Updated by drebs over 1 year ago

drebs wrote:

This is an up-to-date list of hard deps for Weblate 2.19 and their relation to Debian packages:
...
So, in summary, we'd need to create 4 new packages (and backport them) and also backport 4 other packages.

Actually, there is one more packages to create because deps of deps are missing in the table above. social-auth-core has already been uploaded. These are the deps of deps for the direct deps of Weblate that are not yet packaged for Debian:

siphashc 1.0:
  • No deps.
social-auth-app-django 2.1.0: user-agents: ua-parser 0.7.3:

So this amounts to a new total of 4 missing packages, not counting social-auth-core, as it's been uploaded, and counting one new dep of dep. The missing packages are: siphashc, social-auth-app-django, user-agents and ua-parser

#18 Updated by drebs over 1 year ago

Here are ITPs on the Debian BTS for the missing packages:

There's some ongoing discussion about how to handle a cross-package dependency of ua-parser that might need packaging itself.

#19 Updated by drebs over 1 year ago

Update:

Still missing: siphashc and user-agents.

There's something else that is missing that the sponsor asked us to do, which is to go through the code of Weblate to find third party libraries or other dependencies that are not explicitelly listed as such (as for example this javascript file that is part of this third-party library). For these cases, we can either (ideally) file RFPs and then proceed with separating and packaging them or use embedded copies (if upstream needs an exact version and the Debian package is too new or too old).

#20 Updated by drebs over 1 year ago

Meanwhile, Weblate 3.0 was released, and this table compares dependencies previously mapped for 2.19 to current dependencies for 3.0:

Python module dep for 2.19 dep for 3.0
Django >= 1.11 >= 1.11
siphashc >= 0.8 >= 0.8
Translate-toolkit >= 2.2.0 >= 2.3.0 (is in buster)
Six >= 1.7.0 >= 1.7.0
filelock >= 3.0.1 >= 3.0.1
social-auth-core >= 1.3.0 >= 1.3.0
social-auth-app-django >= 1.2.0 >= 1.2.0
django-appconf >= 1.0 >= 1.0
Whoosh >= 2.7.0 >= 2.7.0
PIL or Pillow library
lxml >= 3.1.0 >= 3.1.0
defusedxml >= 0.4 >= 0.4
dateutil
django_compressor >= 2.1.1 >= 2.1.1
django-crispy-forms >= 1.6.1 >= 1.6.1
Django REST Framework >=3.7 >= 3.8 (is in buster)
user-agents >= 1.1.0 >= 1.1.0
oauthlib >=0.6.3 not listed
phply not listed any (1.0.0 in stretch, 1.2.4 in buster)
python-levenshtein not listed recommended for performance (in stretch)

It's worth to mention here that the team is currently discussing what is the best option to upgrade and maintain Weblate in production for the longer term. The options are, currently, package everything to Debian, install python modules from Git and pin versions, or use Weblate's upstream docker image. We are currently debating what's the sanest option for short and long terms.

#21 Updated by u about 1 year ago

  • Description updated (diff)

#22 Updated by u about 1 year ago

  • QA Check set to Info Needed

I don't understand if PIL or Pillow library and dateutil are requirements for Weblate 3.0?

#23 Updated by u about 1 year ago

  • Related to Feature #10037: Help Weblate maintainers to add the package to Debian added

#24 Updated by u 7 months ago

  • Parent task set to #10034

#25 Updated by u 6 months ago

  • % Done changed from 40 to 70
  • QA Check deleted (Info Needed)

#26 Updated by u 6 months ago

  • Status changed from Confirmed to In Progress

#27 Updated by u 2 months ago

  • Parent task deleted (#10034)
  • Affected tool set to Translation Platform

#28 Updated by intrigeri 5 days ago

  • Assignee changed from drebs to intrigeri

I'll do this today.

#29 Updated by intrigeri 5 days ago

  • Target version set to Tails_4.0

#30 Updated by intrigeri 5 days ago

As of Weblate 3.8 what's missing in Buster among requirements.txt:

  • in testing/sid:
    • translate-toolkit == 2.4.0
    • jellyfish >= 0.6.1
    • python3-diff-match-patch == 20181111
  • needed version is not in Debian at all
    • oauthlib >= 3.0.0 (sid has 2.1.0-1)
    • openpyxl >= 2.6.0 (sid has 2.4.9-1)
    • translation-finder >= 1.4 (sid has 1.0-1+b1)
  • package not in Debian at all

#31 Updated by intrigeri 5 days ago

  • Status changed from In Progress to Resolved

I've pointed #16943 to the previous comment. There are RFPs for the missing deps. So I don't think there's anything else to do here :)

Also available in: Atom PDF