Project

General

Profile

Feature #10010

Feature #5663: Return to Icedove

Feature #10007: Hide irrelevant TorBirdy options

Decide how long to keep Claws Mails once we have Icedove

Added by sajolida over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08/14/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:

Related issues

Related to Tails - Feature #10167: Remove Claws Mail Resolved 05/29/2015

History

#2 Updated by sajolida over 4 years ago

  • Target version set to Tails_1.6

I can lead that discussion...

#3 Updated by BitingBird over 4 years ago

What was discussed during the summit was something between 3 and 6 months, I think.

#4 Updated by intrigeri over 4 years ago

Say we ship Icedove in Tails version N.

I propose that we include Claws Mail in versions N and N+1, and drop it in N+2, so that users have 3 months (until N+2 is out) to migrate. I have no specific reason to hurry, other than the ones we have for migrating away from Claws Mail.

If someone prefers a longer transition time, please take into account that if we keep Claws Mail in Tails 2.0, then we need to test and support the migration from Wheezy's Claws Mail to Jessie's (it might be trivial, but checking it will take time and would need a volunteer).

#5 Updated by sajolida over 4 years ago

Personally, I'd propose to drop Claws in Tails Jessie. I'm always worried about changing stuff too fast, and here we have a very good reason not to keep it in Tails Jessie, so that looks like a reasonable deadline. And maybe the N+2 as proposed by intrigeri will be Tails Jessie anyway.

#6 Updated by sajolida over 4 years ago

Just to be extra explicit: once we have Icedove it should replace the Claws Mail icon from the application shortcuts, and Claws Mails should only be accessible from the Applications menu.

#7 Updated by intrigeri over 4 years ago

Just to be extra explicit: once we have Icedove it should replace the Claws Mail icon from the application shortcuts, and Claws Mails should only be accessible from the Applications menu.

+1

#8 Updated by intrigeri over 4 years ago

Personally, I'd propose to drop Claws in Tails Jessie. I'm always worried about changing stuff too fast, and here we have a very good reason not to keep it in Tails Jessie, so that looks like a reasonable deadline. And maybe the N+2 as proposed by intrigeri will be Tails Jessie anyway.

Hopefully Tails Jessie <= N+2, otherwise $someone will have to do quite some painful work and ditch it 6-12 weeks later.
If Tails Jessie >> N+2, then we'll have to reconsider and see if someone volunteers to do that work.
No need to bother about discussing this much more now IMO, as I'm quite hopeful about Tails Jessie <= N+2.

#9 Updated by sajolida over 4 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)

Marked as resolved, then.

#10 Updated by intrigeri over 4 years ago

  • Status changed from Resolved to In Progress
  • Assignee set to kytv

Marked as resolved, then.

I think this should first be summed up on the blueprint, so that our plans are clearly outlined somewhere.
Also, if we don't have any yet, we need a ticket to remove Claws Mail.
I'll let kytv do both.

#11 Updated by kytv over 4 years ago

#12 Updated by kytv over 4 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (kytv)
  • % Done changed from 0 to 100

Ticket #10167 created, Icedove blueprint updated.

Also available in: Atom PDF