Project

General

Profile

Feature #10009

Feature #5663: Return to Icedove

Decide whether to disable remote email account creation in Icedove

Added by sajolida almost 4 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08/14/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:

Description

We're told that Icedove's account creation wizard can create a mailbox on remote servers. Can we, do we want to support that?

get a new account.png View (24.5 KB) sajolida, 09/28/2015 10:46 AM

would you like a new email address.png View (43.1 KB) sajolida, 09/28/2015 10:46 AM

History

#1 Updated by sajolida almost 4 years ago

  • Assignee set to kytv
  • Parent task set to #5663

Marking is for kytv as the one working on Icedove integration. Maybe you should test whether this is still activated with TorBirdy, and whether we can disable it. Then raise the issue in a monthly meeting if we cannot find a clear agreement quickly on the ticket.

#3 Updated by kytv over 3 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

After poking around in Icedove's options/menus for some time I'm quite confident in saying that it is not possible to create an account on a remote server within Icedove when Torbirdy is installed.

Closing as resolved.

#4 Updated by intrigeri over 3 years ago

  • Status changed from Resolved to In Progress
  • % Done changed from 100 to 50
  • QA Check set to Info Needed

After poking around in Icedove's options/menus for some time

Just to make sure: did you test that from Icedove's account creation wizard (which this ticket is about), or did you do this poking around in a context where it was disabled (which is probably the case in your Icedove branch I guess, since that's how we want to ship things in Tails 1.7)?

#5 Updated by kytv over 3 years ago

  • QA Check deleted (Info Needed)

intrigeri wrote:

After poking around in Icedove's options/menus for some time

Just to make sure: did you test that from Icedove's account creation wizard (which this ticket is about), or did you do this poking around in a context where it was disabled (which is probably the case in your Icedove branch I guess, since that's how we want to ship things in Tails 1.7)?

The Torbirdy source includes

  // Check if we are running Tails. If yes, disable the manual account
  // configuration wizard since Tails handles that on its own. See:
  // https://tails.boum.org/todo/Return_of_Icedove__63__/#index6h2
  // This is also disabled if "extensions.torbirdy.emailwizard" is true.
  var disableWizard = false;
  if (prefs.prefHasUserValue("vendor.name")) {
    if (prefs.getCharPref("vendor.name") === "Tails") {
      disableWizard = true;
    }   
  }
  if (prefs.getBoolPref("extensions.torbirdy.emailwizard")) {
    disableWizard = true;
  }

With pref("vendor.name", "Tails"); set I didn't see the account creation option. Looking at it again after disabling Torbirdy and seeing the default Icedove 'wizard' it seems that this setting may not have been respected.

#6 Updated by sajolida over 3 years ago

Just to clarify which objects we're talking about here are two screenshots.

  • "get a new account.png" is the initial window of the account creation assistant when launched from the menu "Account Settings" → "Add Mail Account", for example to configure a second email account. We should aim at removing the "Get a new account" buttom from this windows once we have the default Icedove assistant.
  • "would you like a new email address.png" appears in two circumstances:
    • It's the very first screen to appear when first starting Icedove in Tails with Tor Birdy disabled (no account created yet).
    • It's the screen that appears when clicking the "Get a new account" button from the wizard as described in the other screenshot.

We should aim at never displaying this screen unless we really want this feature.

#7 Updated by kytv over 3 years ago

  • Blocked by Feature #6154: Secure the Icedove autoconfig wizard added

#8 Updated by intrigeri over 3 years ago

  • Target version set to Tails_1.8

(1.8 is the latest milestone before M4)

#9 Updated by kytv over 3 years ago

sajolida wrote:

We should aim at never displaying this screen unless we really want this feature.

+1. I'd personally prefer that this feature goes away unless we want to direct people to a service that we trust, e.g. "riseup". Do we want that? Would riseup (for example) want that?

#10 Updated by anonym over 3 years ago

kytv wrote:

Would riseup (for example) want that?

I doubt it. Their mission is not to provide email (and their other services) for everyone.

#11 Updated by sajolida over 3 years ago

Same here, I would disable this feature all the way.

#12 Updated by sajolida over 3 years ago

  • Blocked by deleted (Feature #6154: Secure the Icedove autoconfig wizard)

#13 Updated by sajolida over 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (kytv)

It seems like we all agree.

#14 Updated by intrigeri about 3 years ago

  • % Done changed from 50 to 100

Also available in: Atom PDF